This is a read-only archive of the Framer Community on Facebook.

What is Framer? Join the Community
Return to index
Fran Pérez
Posted Oct 28 - Read on Facebook

I'm trying to import the library shake.js into Framer through npm, but I'm getting this error. Does anybody knows what's going on?

I'm following this: https://framer.com/docs/#modules.npm

3 Comments

Jiwoong Lee

did you install npm or node.js? maybe it needs to be done first? (I never tried this though. :)

Fran Pérez

Sorry, the installation through NPM is not the problem, I should've been more clear. The problem is when importing/requiring…

Jiwoong Lee

I just tried it and it seems like there need to be npm.coffee in modules folder which contains this.

exports.Shake = require "shake.js"

did you do it? after having this, I have no problem with importing. good to know about this btw. thanks! :)

Read the entire post on Facebook