This is a read-only archive of the Framer Community on Facebook.

What is Framer? Join the Community
Return to index
Agisilaos Tsaraboulidis
Posted Oct 05 - Read on Facebook

Hey guys, I updated the framer Library in a rush and now I have this error what I need to do to fix it?

5 Comments

Niels van Hoorn

Hi Agisilaos,

Ouch, that definitely shouldn't happen! Is is possible to share your prototype so I can take a look and fix it?
Also: when updating your Framer version, we copy the current version to framerjs.old in the framer folder in your project, so you can restore the old version from there.

Agisilaos Tsaraboulidis

of course, here's the prototype: http://share.framerjs.com/2mbmb85zdwr4/

Niels van Hoorn

Cool prototype! I got it to work again: http://share.framerjs.com/6e7tk75jo01e/

The problem was with some features that the ViewController class used, that we removed as optimisation in the new library. I changed it a bit to get it working again, but functionally it shouldn't be different.Could you point me to the specific location you retrieved ViewController from, so we can fix this problem at the source? :)

Agisilaos Tsaraboulidis

Oh thanks 😁 What you mean exactly? I used a VC module

Agisilaos Tsaraboulidis
Read the entire post on Facebook