This is a read-only archive of the Framer Community on Facebook.

What is Framer? Join the Community
Return to index
Ash Adamson
Posted May 19 - Read on Facebook

Have you ever imported a sketch file where a sketch group is displaying correctly but it’s coordinates are (0,0) ?

Has anyone solved this issue before?

Sketch Group 1 - is a box and is showing up properly in the X/Y placement in framer.

Sketch Group 2 - is displaying the correct location on the screen, but has X/Y of 0,0. When it's real X/Y should be 181, 120.

10 Comments

Stephen Crowley

I haven't. Mind if I take a look at your sketch file?

Andrew Nalband

I'm not sure, is group 2 scaled at all?

Ash Adamson

No code in this, just an import. Here's the sketch file: Stephen Crowley/ Andrew Nalband https://www.dropbox.com/s/7i0m1fglhr9hyt8/dataexplorer_prototype-fix.sketch?dl=0

Ash Adamson

If you import it, you might get the same results.

Andrew Nalband

yep, same results

Ash Adamson

weird right?

Ash Adamson

Oh! I fixed it, the problem is that I was using the "-" after a nested layer which may of been causing the parent group to be ignored. This is supposed to be a feature, but I think it's not supposed to work like that.

From Framer Blog: "You can now insert a minus after the layer name to ignore a layer group. You can still use an * to flatten a layer group."

Andrew Nalband

BAM, nice

Stephen Crowley

?

Koen Bok

Feels like a good time to ask what I should fix :-) So the - switch has an effect on its parent coordinates?

Read the entire post on Facebook