This is a read-only archive of the Framer Community on Facebook.

What is Framer? Join the Community
Return to index
Edgar Lechaudel
Posted Sep 15 - Read on Facebook

Hi Framers!

Could someone explain to me the reason why the property Scale of a layer delayed the Spring Curve animation? See the video below to notice the issue I'm facing...

thank you very much guys!

5 Comments

Edgar Lechaudel

By trying a few things to get the problem fixed it seems that I figured it out. there was a conflict between the property Visible and the Animation. By replacing the property Visible with an Opacity property the animation is now working properly.

The only thing is that the animation works only once. for repetitive usage the spring animation with a scale from 0.8 to 1 doesn't fire anymore...

Fran Pérez

Try adding some tolerance to your spring curve, something like: "spring(300, 30, 0, 0.015)"

Edgar Lechaudel

Hi Fran, thanks for your reply! I've fixed the issue by replacing the property Visible with an Opacity property. It is now working properly.

I've now an other issue... (see first comment) Maybe you can help me on this topic too. the scale animation + spring curve is not firing on repetitive usage. Any ideas?

Gabriel Lovato

Most likely because your object is already at scale 1 after your first animation, you need to set it back to .8 before refiring the animation

Edgar Lechaudel

Thanks Gabriel! I'm going to try that soon. I'll let you know. ;)

Read the entire post on Facebook