This is a read-only archive of the Framer Community on Facebook.

What is Framer? Join the Community
Return to index
Jérémy Jones
Posted Jul 08 - Read on Facebook

Hey guys, I'm trying to use Typekit and I have a question.
What do you put inside the domains input?
http://cl.ly/image/471S0o3o0u2Y

I tried localhost,etc... but I can't see my font..
Also, I put the javascript from Typekit inside my index.html.
Thanks!

9 Comments

Chris Camargo

When you are viewing your prototype in a browser, does the URL bar say "localhost" or does it show your IP address? If it's the latter, make sure you provide TypeKit your specific IP address under domain, excluding the port number.

Jérémy Jones

What do you mean by viewing on a browser?

Chris Camargo

Sorry, Jérémy, I think I misunderstood your problem. If you want to view fonts in the Framer Studio preview pane, 127.0.0.1 should work. My guess is something isn't being setup right in either your index.html file, or you're not invoking your fonts properly in your prototype code.

Jérémy Jones

Chris Camargo Yep I have to double check, like you said 127.0.0.1 should work .. :)

Chris Camargo

FYI, here's how I applied custom fonts in the past.

Chris Camargo

Then I just specify classes in the layer's html.

Jérémy Jones

Chris Camargo Thanks!

Jordan Robert Dobson

Whoa Chris. Never looked at that CSS before. Does it go to the root of the doc?

Chris Camargo

It appears to append them to the body of index.html as its rendered.

Read the entire post on Facebook