This is a read-only archive of the Framer Community on Facebook.

What is Framer? Join the Community
Return to index
Gary Jacobs
Posted Feb 23 - Read on Facebook

Has anyone gotten this to work on mobile. http://codepen.io/koenbok/full/AvGqn

As soon as I try to drag it on a touch device (iPhone/iPad) the little balls x and y coordinates seem to return to 0 rendering the ball to the top left of the bound view. It works as expected on the desktop browser but not mobile.

I'm trying to recreate a pull to refresh animation (http://www.fromtheloft.com.au/prototypes/pullToRefresh/) which doesn't seem to be working on mobile safari.

Any ideas?

4 Comments

Gary Jacobs

Hello. Anyone experienced this?

Marc Krenn

Looking at the example's code, it's probably due the lack of using the proper code for mobile inputs. Don't quote me on that one, but I think it's an expected - although, not wanted - behavior.

Since I don't have any experience with mobile inputs, you should take my advice with a lot of salt:

However, try using "Events.TouchMove" instead of "Events.DragMove" and "Events.TouchEnd" instead of "Events.DragEnd". On top of that you should probably look into using fastclick.js (https://www.facebook.com/groups/framerjs/permalink/422639967863080/) to compensate your mobile browser's 500ms input delay.

Hope that helped, for now :)

Gary Jacobs

Thanks for the reply Marc Krenn.
I've changed the dragMove and dragEnd to touch but that didn't work for me.

I've already got fastclick integrated on that code I posted, so I know it's not that. I'll keep trying.

Cheers.

Marc Krenn

Dammit, I'm sorry, Gary :/

Read the entire post on Facebook